Block Torrent Connection on MikroTik

In this article, i will share about How to block torrent connection on MikroTik

If someone do a torrenting, it will consume extra (and unusual) bandwidth. Especially if your ISP apply a different bandwidth rule between domestic and international, it will be annoyed for other international connection. Or, if someone do an “illegal” download over torrent, some ISP will notice you regarding “Copyright download”. So you must drop the torrent connection

Brief history : i got a copyright notice from Vultr, because my VPN client was download over torrent using my connection (FYI, i have 2 servers, one from domestic and one from Vultr SG. I did a tunneling between 2 servers using IP Tunnel, then from my domestic server i did a route some /8 IP to Vultr SG). So, i was think “how to drop torrent connection”. Now, i found the solution. Hope it will effective

Step for block torrent connection (Note that I’m using Filter option. If you are using Raw method, no problem) :

1. Navigate to IP > Firewall > Filter

2. Follow this guide.

  • Chain : forward (if you are using raw, select prerouting option)
  • Protocol : tcp
  • Dst Port : 3000,6771,6881-7000,9000,9091
  • Action : Drop
  • Note : Do the same rule with udp option

3. Then, create rule again. In Advanced > Content, fill d1:ad2:id20: in Content section. For action, select Drop (FYI : This is DHT protocol)

Script method. You can paste it to terminal :

/ip firewall filter
add action=drop chain=forward comment=TORRENT dst-port=3000,6771,6881-7000,9000,9091 protocol=tcp
add action=drop chain=forward dst-port=3000,6771,6881-7000,9000,9091 protocol=udp
add action=drop chain=forward content=d1:ad2:id20:

How it works? If someone want to do a torrenting, it will block DHT protocol. Also, it will block tracker and other connection related torrent in Dst Port section

The result. Note that rule number 2 is DHT protocol

That’s it. Now, if someone doing a torrent, it is not possible because it has already blocked. So, you can use your connection for other which is important. I will update my post, if it must be change on port or protocol. Hope it will effective for your network ^_^