RouterOS Script for Block Facebook Connections with TLS

In this article, i will share about how to block Facebook / Instagram / WhatsApp connection on MikroTik Routers

Script for block Facebook

/ip firewall filter
add action=drop chain=forward protocol=tcp tls-host="*facebook.com*"
add action=drop chain=forward protocol=tcp tls-host="*fbcdn.net*"

Script for block Instagram

/ip firewall filter
add action=drop chain=forward protocol=tcp tls-host="*instagram.com*"
add action=drop chain=forward protocol=tcp tls-host="*cdninstagram.com*"

Script for block WhatsApp

/ip firewall filter
add action=drop chain=forward protocol=tcp tls-host="*whatsapp.com*"
add action=drop chain=forward protocol=tcp tls-host="*whatsapp.net*"